month/categories Error: Not Found

Hi,

 

When trying the get information from a single category for a specific month, I'm getting a 404.2 error - "resource not found".

It's occurs even when tested from the API Endpoints docs.

When i'm using the PATCH method to update the month category, I'm getting the same error but the budget seems to be updated.

What am I doing wrong?

 

Thanks,

Moshe

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Beige Cup wrote in to support and helped me find the bug on our end. We've got a good repro and a fix should go out next Tuesday.

    To work around the bug in the meantime, simply use the first of the month in your `month` URL segments. Good: 2019-01-01.  Buggy: 2019-01-15.

    I'll post here when the fix goes out.

    Like
  • The fix for this bug has been pushed to production. You can read more in the "API News" section of the release notes. Thanks again for writing in, Beige Cup .

    Like
  • Hi,

    Looks like this bug may be back in production.

    I had the same experience as the OP. Couldn't get the GET endpoint to work on my client using the first date of the month ("2020-12-01"), so I tested it in your Swagger interface and got the same 404.2 error:

    {
      "error": {
        "id": "404.2",
        "name": "resource_not_found",
        "detail": "Resource not found"
      }
    }

    Here's the endpoint for reference: https://api.youneedabudget.com/v1#/Categories/getMonthCategoryById

    Thanks for any help.

    Like
Like1 Follow
  • 1 Likes
  • 1 mth agoLast active
  • 3Replies
  • 128Views
  • 2 Following