How do I remove duplicate transactions?

I enter my transactions manually when I spend the money.

Later, when YNAB syncs with my bank, it sees the same transaction and records it as a new one. I've tried matching the payee when approving them during import, but it still thinks they're two separate transactions.

My budget is a mess now and can't be trusted.

How do I manually delete duplicates in YNAB? And how do I prevent this problem in the future?

10replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Ynab should be letting you match them. Contact support to troubleshoot why you can’t. 

    you can always delete one of the transactions

  • Hi  Jayson Elliot ! I'm happy to help get to the bottom of this. Did you enter those yourself, or maybe with File-Based Importing? A way to check if your entered transaction has been matched is to click on the Payee and check for Bank Import Details.

    Imported transactions from your bank will automatically match up with transactions you’ve entered—as long as the amounts match exactly and the transaction dates are within 10 days of each other. You can also manually match an imported transaction with one you entered. File-based are considered imported.

    If you see the same transaction twice (same Bank Import Details), you can report a Bank Importing Issue here—and grab a quick screenshot of the example. Our team will help get to the bottom of it!

    Like 1
    • To remove duplicates from your register, select the transactions you don't need using the checkboxes to the left (or the top checkbox to select them all at once) and choose Edit > Reject. And make sure to reconcile too.

      An example will help us get it reported, but once you grab that—you're safe to remove those, and we'll dig in.

    • Nicole Thanks. I've sent a report to the support link you provided. I didn't include a screenshot there because it didn't seem to have a place for one.


      Basically, a transaction that I entered manually is showing up again as a different transaction after sync. The amounts and payees are identical, and the dates are just one day apart.

      Like 1
    • Jayson Elliot Thank you! I sent you an email. 😄

  • I have the same problem of not being able to match transactions automatically of manually. It worked in YNAB 4 but not in YNAB online. Part of the problem is that the banks change the date of the transaction everyday while it's being authorised until it's finalised.

    If YNAB online could look at the $ value only then it would work, but they look at the date too. :(

    • Lavender Tiger Is there an example in your budget right now? I'd be happy to hop in and take a look, if you're up for enabling Support Access.

      One imported transaction will match with one entered transaction. So if you're not able to manually match those, it sounds like it may be a duplicate import.

      • Heidi
      • Lavender_Tiger.16
      • 5 days ago
      • Reported - view

      Nicole Yes please Nicole. Help would be great with this bug. There are a number of these transactions in my budget right now that won't match and have been imported multiple times.

    • Thank you, Heidi ! It looks like the dates vary between the File-Based imported transactions in the file you downloaded from the bank. For those to be skipped, the date and amount needs to be the same—and since both are imported, they won't manually match either. In this case, you'd need to delete  the extra one.

      That said, I have a few questions about the formatting in the file—to see if we can get this working smoother for you! I sent you an email, with a few questions and we'll continue there. 🙂

  • I don't get all the matching issues to be honest. I don't have them. I have lots of recurring transactions I put in the scheduler that direct import always match up with with different dates.

Like1 Follow
  • 4 days agoLast active
  • 10Replies
  • 91Views
  • 7 Following