USAA linked but not importing data

Hi there, sometime around July 15 or thereabouts the link to USAA appears to have stopped working. I can link my account and it says that it is downloading the information, but it doesn't actually pull in any new transactions even though I know there are some.

46replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • We're closing out Bank Importing threads in the forum to make sure these issues are better resolved.

    Replies in this thread have been turned off, but if you’re having trouble with your bank, please fill out this form and our Direct Import team will help you get things back up and running!

    Like
  • I'm having the same issue.  I re-authenticate daily but no new transactions are imported.

    Like
  • +1 - seems to have stopped a couple of days ago. I'm manually clearing our accounts right now.

    Like
  • Yep, same here. Auth works but expires quickly, and no new transactions are imported afterward.

    Like
  • I'm having the same problem. I've re-authenticated my USAA credentials 4 times but the problem recurs the next day, with no transactions imported.

    Like
  • I'm having a similar issue with USAA. I have two-factor authentication on with USAA and it's having me re-enter that every day. There is something wrong with the integration so I imagine that YNAB will have to fix it. I contacted their support but have not heard back yet.

    Like
  • I'm also getting a message that USAA transactions are not working and that YNAB is performing maintenance. Does that mean I should hold tight, or try deleting the connection and re-connecting?

    Like
  • Same here...... Whats going on YNAB? Can we get an official response. This is super inconvenient!

    Like 1
  • Hi all!

    Thanks for reporting this issue with USAA. One of our YNAB team members who is also a USAA member also noticed her account had stopped importing a couple of days ago and began requiring daily reauthorization.

    We discovered that USAA recently updated their security protocols, which is going to require regular reauthorization and also created some duplicate accounts. 

    Sometimes accounts can duplicate and sort of "dead-end" on the backend of YNAB -- this can happen when the financial institution makes updates or changes to the metadata of those accounts.

    To clear out those duplicate accounts, you can refresh that connection. It’s done by removing it, which is different than disconnecting the account, and it seems to do the trick for this issue!

    You can do that from the web app or the mobile app.

    If transactions still aren’t importing once you've refreshed the connection and relinked your account(s), let us know so we can work with our import partner to figure out what’s going on. We’ll just need to know:

    • the name of the account(s) not importing.
    • the date and amount of a few recent transactions that have posted to your bank account but haven’t imported (or you can send a screenshot, if that's easier!)

    You can send us a message in the app and we're happy to look into it!
     

    Like
    • Scott Annen Slate Gray Screwdiver tandigidy Transcend Altitude 
      Cadet Blue Trumpet Green Captain Slate Gray Sidewinder Sea Green Sloth

      Give those steps a try and let us know how it goes! 

      Like 1
      • RIP_MSMoney
      • FinTech Programmer
      • rip_ms_money
      • 3 mths ago
      • 1
      • Reported - view

      Nicole sending message now as none of my accounts are importing but are linked successfully.

      Like 1
      • tandigidy
      • Navy_Blue_Transistor.7
      • 3 mths ago
      • 1
      • Reported - view

      Nicole This did not fix the issue. I also removed the account and then readded it and linked it again and the two-factor authentication still comes up daily for me to manually enter a code in. Once I enter in the two-factor code, the new transactions download. I don't want to have to re-authenticate YNAB with USAA daily. Do you know when the integration will be fixed?

      Like 1
    • tandigidy I took a peek on our end, and your USAA Bank connection is successful, and importing transactions! How does that look for you?

      Many financial institutions are increasing their security, and we've found having to re-authorize your account is expected behavior. You don't need to re-authenticate the connection every time it asks—just go through the prompt when you're ready to import new transactions. We hope this will improve in the future, but at this time, it's not something we or the import partner can get around.

      Like
      • tandigidy
      • Navy_Blue_Transistor.7
      • 3 mths ago
      • Reported - view

      Nicole Re-authenticating every time I want to pull in transactions is very frustrating.

      After playing with this for a couple of weeks I seem to have found a solution. There is a way to get these transactions to automatically come into YNAB.

      To resolve the issue, I had to enable computer recognition in USAA and then enter into YNAB the answers to my security questions over the next several days. I've attached a screenshot of my security settings in USAA.

      This solution is less secure than two-factor authentication, but this risk is pretty low. I'm ok with the risk given the convenience of having YNAB automatically import transactions!

      I hope this helps others!

      Like
    • Hi tandigidy ! I know those frequent re-authorizations  can be a frustrating experience, and I'm sorry that's the case.

      I replied to you in another thread, but wanted to include the information here as well. A few forum YNABers have mentioned receiving an email that USAA is removing the Computer Recognition option, and moving all users to two-factor authentication.

      If that sticks around, we'd love to know—so we can pass that tip on to other USAA YNABers.

      Like
  • Thanks Nicole for your response! When I try to re-add the connection after removing it, YNAB reconnects to USAA successfully, but is unable to detect any USAA accounts (it lists 0/0 connected on the Manage Connections screen). Has anyone else had this same problem or gotten their accounts to sync by refreshing the connection?

    Like 1
    • Hi Cadet Blue Trumpet !

      It sounds like you may be running into a different USAA issue. I sent you a quick email to get a few more details! :)

      Like
  • I have unlinked and relinked. Still no transactions. I checked my register and July 15th is where mine stopped as well....

    Like
    • Hi RIP_MSMoney ! I'm seeing transactions last imported on the 19th. Can you let me know things are looking on your end? If you're still not seeing transactions import, just respond to that last message from Carrie with the details she mentioned. We're happy to investigate!

      Like
      • RIP_MSMoney
      • FinTech Programmer
      • rip_ms_money
      • 3 mths ago
      • 1
      • Reported - view

      Nicole thinks are now looking better. Transactions finally imported an hour ago.

      Like 1
  • I just logged on to USAA this morning to manually clear my accounts. I was prompted for a new kind of MFA to text a code to one of my phone numbers. I've never seen this before, so USAA has obviously changed something up.

    Like 1
  • It does seem like USAA changed something. I also use Quicken and Personal Capital.

    1) Quicken still seems to work
    2) Personal Capital prompted me to enter a Security Code texted to me but subsequent connections seem to be working without manual intervention and transactions were retrieved

    3) YNAB prompted me to enter a Security Code but doesn't appear to be downloading transactions  even after the connection is fixed.

    Like 1
      • RIP_MSMoney
      • FinTech Programmer
      • rip_ms_money
      • 3 mths ago
      • Reported - view

      Orchid Lobster #3 is what I get as well.. :(

      Like
    • Hi Orchid Lobster and RIP_MSMoney !

      Can you share with me when you relinked your accounts? Since it's the weekend, it's possible transactions won't clear until Monday and won't import until late Monday or Tuesday. Also, when you relinked the account did you notice any duplicates like Nicole mentioned above?

      If so, when you relink your accounts, select the option with the closest written-out name to your account (such as "Signature Visa" or "USAA Savings") rather than numbers (such as ***2501).

      If transactions still aren’t importing in the next few days, let me know so I can work with our import partner to figure out what’s going on. :)

      Like
  • I went to "Add Account" and noticed that in the list of linked accounts was my checking account with the balance prior to the connection not working, and a new checking account with my current balance. Since it's the weekend, I don't know if the checking account with the current balance will start importing transactions correctly now that I've added it. 

    Like 1
    • Hi Khaki Motherboard !

      I'll keep my fingers crossed that does the trick! When those duplicates appears, you want to select the option with the closest written-out name to your account (such as "Signature Visa" or "USAA Savings") rather than numbers (such as ***2501). 

      If transactions still don't appear in the next few days, please let us know and we'll go from there! :)

      Like
  • Same issue here. I reauthorize and it says the connection is good but no transactions download into YNAB.

    Like
    • Hi KnitPurlKnit !

      Sorry for the trouble!

      Did you try to remove and then re-add the connection? It's a bit different from reauthorizing. 

      You can do that from the web app or the mobile app. When you relink your accounts, select the option with the closest written-out name to your account (such as "Signature Visa" or "USAA Savings") rather than numbers (such as ***2501).

      If you still aren't seeing new transactions import in the next few days, please let us know!

      Like
    • Faness I'm having the same problem. Followed the instructions to remove and then relink the account. Now it shows 0/3 accounts linked.

      Like
    • Faness I did as you asked. Removed and then re-added. The connection worked but the following happened:

      All transactions from 7/1/2019 were re-downloaded into the wrong USAA account. I have 2 USAA accounts: 1 for savings , 1 for checking. All 30 transactions were downloaded into the savings account when they should have been downloaded into the checking account. I can change the account on all these transactions, but they're all appearing as new transactions, even though all but 1 have already been cleared and reconciled. Not sure what to do with them all at this point. So now my budget is completely messed up, showing a big positive TBB number and many overspent categories. 

      Like
    • Hi Turquoise Horn !

      It looks like there is a successful connection to USAA, but the accounts haven’t been re-linked just yet. Can I have you try to link the account to the connection? 

      1. Hover over the existing account (in the left sidebar) and click on the edit icon.

      2. Select Link Account and choose your USAA connection, and follow the prompts.

      Let me know how it goes!

      Like
    • Hi KnitPurlKnit ! It looks like your checking account might be linked to a different account on your connection. I've reached out via email, so we can sort it out!

      Like
    • Nicole I got this figured out! I deleted all the transactions that imported to the wrong account and then re-established the connection again from the beginning. All seems well now. I also called USAA yesterday to ask about 3rd party integration and their new security feature. I was told that YNAB won't be able to download new transactions into your USAA accounts UNLESS you do the text message thing before every download. I personally don't find this to be a problem for me as it's quick and easy. The confirmation number that contains the text pops up on both my phone and my laptop (MacBook) almost immediately,  and once I enter the 6 digit code, the new transactions have been downloading very quickly. 

      I agree that it's not quite as convenient as having the new transactions appear automatically without having to do anything but for me the added security is well worth the extra 5-10 seconds it takes. Just my $0.02.

      Like
  • Hi- I tried removing and readding, then linking the accounts. It's still the old numbers. Now what? Do I need to wait and if so, how long?

    Like
    • Purple Falafel Thanks for giving those steps a try! I've sent you an email, to gather a few more details and move on to the next step.

      Like
    • Nicole Thank you! I did write you back. It finally worked, an hour or so later.

      Like 1
  • I have done all the steps that was given to relink my USAA accounts and when I do it just states 0/6 accounts were linked...I havent had a transaction imports in  over 5 days....Please help!!

    Like
    • Hi Silver Drum ! You're halfway there. 😄

      The accounts haven’t been re-linked just yet. Can I have you try to link the account to the connection? 

      1. Hover over the existing account (in the left sidebar) and click on the edit icon.

      2. Select Link Account and choose your USAA connection, and follow the prompts.

      You'll follow those same steps for each account you'd like to link. Let me know how it goes!

      Like
  • I'm still having trouble getting it to connect, I've tried deleting and re-adding the connection every morning for several days and I just get a message that the connection is in Maintenance. I don't think this is quite the same error others are getting, is there something else I should try?

    Like
    • Hi Slate Gray Screwdiver ! You're right. That maintenance error is a separate issue, and our import partner is troubleshooting with a fellow YNABer, who volunteered to help the cause.

      We'll post updates on our status page as things progress. I see you wrote in via email, and my colleague sent a little more detail! Let us know if you have any questions. 😄

      Like
  • My accounts are also not linking

    Like
    • Thanks for reaching out, JR5445 ! I see you wrote in via email, and one of our Direct Import experts will be along shortly to look closer at that connection. 🙂

      Like 1
  • We just fixed this issue for our connection and import resumed.  Full disclosure, I'm writing this after only 5 minutes being repaired.  This could break again tomorrow.

    1. From the main YNAB Screen, click the drop-down menu under My Budget and select Manage Connections.
    2. Click Remove on the USAA Bank connection and accept the "this cannot be undone"  message.
      1. This will not remove your USAA register or account, only the connection to USAA
      2. In essence, this will Unlink all of your USAA accounts and remove the login credentials
    3. From the main YNAB Screen, click the drop-down menu again under My Budget and select Manage Connections.
    4. Scroll down and select Add New Connection and select USAA from the list
    5. Authenticate to USAA through YNAB like the first time you setup your USAA accounts, i.e. username, password, pin, etc.
    6. Once completed, go to each of your USAA registers (checking, savings, etc.) and Link your registers to your new USAA connection.
    7. Click the Import button at the top of each register to initiate the import or just wait for the transactions to appear.
      1. Ours took only a few seconds to import all the new transactions

    Happy YNABing!

    Like
    • I'm glad to hear that your connection is back up & running, Cornflower Blue Cartridge !

      We discovered that USAA updated their security protocols, which means you may need to re-authorize the account prior to each import. You can do this by clicking the Import button in the account register. Or, if you're working in the mobile app, tap the orange banner at the top of the account register. 

      Let me know if you have any questions!

      Like
    • Nicole i dont have an orange banner in my mobile app.... 

      Like
    • Hi Purple Falafel !

      I took a look and your accounts are currently showing as successfully connected. Were you able to connect but you aren't seeing new transactions import?

      Have you already tried our troubleshooting steps? More specifically, have you tried to “remove” the connection (not the account!) and then re-connect? It's different than using the Disconnect (or Unlink) button, you won't lose any data, and it seems to do the trick for most issues! 

      To start, you’ll remove the connection  to this financial institution:

      1. Select your budget name in the top left-hand corner and choose Manage Connections from the drop-down menu.

      2. Then Remove the connection(s) to this financial institution, confirm removal and close the window.

      Then you’ll reconnect your account(s) to a fresh connection:

      3. Hover over the existing account (in the left sidebar) and click on the edit icon. 

      4. Select Link Account > Add New Connection. Search for the financial institution, and follow the prompts.

      If you hit an error that doesn't work itself out within 48 hours, let us know so we can look into it further! :)

      Like
Replies are closed
Like3
  • 3 Likes
  • 3 wk agoLast active
  • 46Replies closed
  • 423Views
  • 22 Following