iPhone 7 and not able to open YNAB app

Hello all,

is anyone else having trouble getting the YNAB app to open on an iPhone 7. When I click on the app the light blue screen with the YNAB logo comes up, sits there for about 30 seconds and then kicks itself out. 

Have tried turning off the iPhone to do a good reboot but no change in the YNAB app behaviour. I have no difficulty logging into the website and strangely the iPad version seems to work okay as well. Not sure what's going on. 

Any thoughts?



8replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Michael,

    Sorry for the trouble! As long as your iPhone 7 is running iOS 11 or later, it should run the mobile app without an issue.

    When you have a moment, can you submit a Bug Report? That way our Bug Specialists can take a closer look at what's happening. :)

      • Bahtoo
      • Tan_Piccolo.5
      • 10 mths ago
      • Reported - view

      Faness I deleted and reinstalled the app and it now seems to work fine. Quite strange as the app worked fine on my iPad. 

      Regarding the bug report - how do I do that?

    • Bahtoo I'm glad you were able to get things up and running! If you click on Bug Report, it takes you to a form you can fill out to have our Bug Team investigate any issues you're having. Since the app is now working, you can skip that step for now, but please let us know if it gives you anymore trouble!

  • Hi, I am currently experiencing a similar problem on IOS 13.3 iPhone 8 Plus.

    After a reboot of the phone I receive a message " Unable to Purchase"

    I have reinstalled YNAB twice now, and rebooted may times.

    The App works fine on iPad and my wife's iPhone 11.

    I have submitted a bug report, hopefully a resolution can be found.

    • Hi Slate Gray Clarinet !

      Sorry for the trouble! Our Bug Team will be in touch to get to the bottom of things! 

  • This little 'glitch' seems to have raised its' head again. Tried opening the YNAB app on my iPhone 7, displayed a blank YNAB start up screen and then after a little while just closed. Tried again today with same result. When I do the double click on the home button it still shows that the YNAB app is open. Did a complete shut down and restart and now works. Not sure for how long though. Annoying!!

    • Hi Bahtoo — Thanks for letting us know you saw it return! If you have a moment, can you submit a new set of logs from the mobile app? I've reached out via email with the steps, and we'll have our Bugs Team dig in. 🧐

  • Addit:  also getting the unable to purchase message again.

Like Follow
  • 7 mths agoLast active
  • 8Replies
  • 101Views
  • 3 Following