The is absolutely ridiculousness!!!!

On my iPhone, I go into the app, see the little blue ball telling me I have new transactions to approve, categorize, etc.  I do all of that.  I'm up to date.  10 minutes later I go onto the web portal and not only are those same approvals waiting there, but because they are now showing up on the web portal they are now showing back on my iPhone app.  This is not the first time.  This is one of MANY.  Just tell me, which is first the chicken or the egg.  Do I just do my transactions on the web and leave the iPhone app alone or vice versa.  This has not always been the case but I'm getting tired of approving the same transactions over and over and over and over and over and over.... well you get the drift.  I love the app but this is getting to frustrating.  I have bible reading that I need to do and can't keep going back and forth with this app lol.... thou shall not keep redoing the same approvals over and over again..  That's written in the book of YNABATIONS 4:12.

23replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Strange.  I don't have this problem.  My wife approves transactions on her iPhone and I use the browser.  We don't ever step over each other.   It could be some issue with how YNAB is identifying pending transactions with your bank.  Are you leaving YNAB up in a browser?  The next time you notice this happening, perhaps do a refresh of your browser and see if they go away.

    Like 3
  • I’ve never encountered this issue either. Definitely recommend contacting support — something sounds screwy.

    Like 3
  • Yep, I've never experienced this.

    Like 2
  • Yes similarly, I've never experienced and I use the app on an iphone.  

    Like 2
  • Delete and reinstall the app on your phone?

    Like 2
  • It sounds like the app isn't getting a chance to sync the changes. Do you have an internet connection when you use it? Are you giving it a chance to sync, not just closing the app a millisecond after entering data? I'm just guessing here, but that's where I'd be looking while support gets back to you.

    Like 1
  • Mr. Alex I just sent you an email to see if we can get this figured out. It's pretty rare to see syncing issues between the mobile and web app, so I suggested some solutions and next steps. Let's keep the conversation going there to get this fixed! :)

    If someone else sees this and is experiencing the same thing, here are some fixes that often work:

    1. Refresh both devices. Try dragging down on the screen in the mobile app to force a sync and on the web app, do so by refreshing/reloading your budget. This should get things in sync!
    2. Refrain from force quitting the mobile app. If you're in the habit of doing this, stop for a few days and see if it clears up the issue.

    If you're still seeing the same issue, get in touch with our team. Send us a Bug Report and we'll help get things syncing smoothly again. :)

    Like 2
      • Mx Emmin
      • Orchid_Banjo.5
      • 3 mths ago
      • 2
      • Reported - view

      Dela I occasionally get it where it takes a few minutes to sync between devices - it's only really noticeable on reconciliation or budgeting days as I dont often switch between devices (Android app & web browser) in short succession otherwise.

      Refreshing both screens has always worked for me, I didnt even realise it was a bug tbh, just a touch of lag/buffering 

      Like 2
    • Mx Emmin Thanks for chiming in! What you described does happen to me, too, occasionally (it did today!). I refreshed both screens and everything synced up. If that ever doesn't happen, though, we want to know about it! ;)

      Like
  • I just decided to use the desktop app. I realize part of it is that as soon as I spend I put it in the app, then the banking finally comes through to tentatively approve and then final approval.  I keep on top of my finances every single day so for right now the desktop it is.  Thanks everyone though.  I will deal with the app or at least figure out the behavior another time.  

    Like 2
  • If it helps, this happens to me as well. Quite a bit in fact. I manage it by forcing a sync on both devices, which I understand should be automatic. It's slightly annoying, but works to keep my phone and computer on the same page. 

    Like 1
  • This happened to me for the first time this week.  I don't recall doing anything weird.  I processed some transactions on my phone.  I came back a few minutes later and all of my work was gone.  Weird.

    Like
    • Cash this does sound odd! When you say you came back a few minutes later, do you mean that you came back to the mobile app, or hopped on to the web app? 

      Like
      • Cash
      • Cash
      • 2 mths ago
      • Reported - view

      Rachel I was using the mobile app.  I was just casually budgeting on the couch and not doing anything terribly complicated with the transactions.  I don't force close apps or anything like that, so I'm not sure what happened.  It was weird, and I remembered this post from the frustrated YNABer.

      Like
    • Cash You're a step ahead of me! Asking if you'd force closed was my next question 😆 If you run into this again (or would like more insight now), would you be up for getting in touch with our bugs team?

      Like
  • So as today is a new month, I waited up for midnight last night and did my budget on my phone (Android). I did some other things in the app (added an upcoming transaction, changed the date on one that hadn't gone through yet, etc.), and then I went out of the app (did not close it, so it was still open in the background.

    This morning, I go in to the web app, and all the money I had assigned last night was not yet assigned. So I went to look at the phone, and it was still assigned there. I did the refresh on both apps and that fixed it, but is there something I should be doing on the app to make sure things make it to whatever central location talks to both apps? Do I have to refresh the phone app after assigning money?

    Like
    • Fuzzball Meows Nope - you shouldn't have to take any additional steps, as long as you weren't force closing the app. 🤔Shoot over a Bug Report if you have a moment!

      Like
    • Fuzzball Meows There is a Background App Refresh setting on iOS, which would cause issues if disabled. 

      Like
    • Marisa But not on Android? (I'm using Android). I will make sure to submit the bug report later today

      Like
    • Fuzzball Meows No! That isn't something that can be changed on Android. Thanks for submitting a bug report!

      Like
  • I noticed the web app today was VERY slow. There was about a 10-second delay with every button press or data entry. 

    Like
    • Sky Blue Tugboat Yikes! That is a lot longer than expected. 🤔I'm not seeing the same behavior, so I think it would be helpful if you would submit a Bug Report.

      Like
      • Bruce
      • Software Engineer
      • Bruce
      • 2 mths ago
      • 1
      • Reported - view

      Sky Blue Tugboat I noticed that too earlier today, but it seems to be pretty snappy right now, so maybe their servers were overloaded with everybody doing their beginning of month stuff on their budgets(?)

      Like 1
Like Follow
  • 2 mths agoLast active
  • 23Replies
  • 435Views
  • 14 Following