RBC Import

Hello,

I am attempting to link my Royal Bank of Canada accounts to YNAB but every time I try it says my username or password are incorrect. I tried earlier today and again this afternoon and still the same error. I changed my banking username and password but same issue. Anyone have any suggestions?

62replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • My issue is that syncing would work for a day and then I would get connection issues because YNAB got the security question wrong and I would have to reset it again..

    Like 1
    • Sky Blue Thunder (767daf21c896) That RBC connection is looking good and you have a new batch to import. If you have further trouble with the security questions, can you reply to that last email? Our team can help get the connection running smoothly!

      Like
    • Sky Blue Thunder (767daf21c896) I was having the exact same issue. Everything would look good but it would only last about 24 hours before I got the same error, and had to log into RBC and clear the security flag asking "was this you?". Super frustrating. I got in touch with support and they helped me through it (they switched me to a different import service?) but what I believe finally worked is removing the RBC connection from YNAB once again, resetting my 3 security questions with RBC to totally different ones, and setting everything up again with YNAB. It did take some persistence but I have not had any more problems in 4-5 days now with daily imports of new transactions, so fingers crossed.

      Like
  • Well, it looks like there is trouble with this again. I got an email from YNAB a couple of weeks ago saying it was resolved, but it's been delayed for me for at least 4-5 days now. Not sure what is going on...

    Like 1
    • Slate Blue Hail If you haven't already, please get in touch with support again—it's the only way we can help with bank importing issues.

      Like
  • Ongoing issue with Royal Bank for me as well. Its been several days. I was hoping that it would work itself out in a timely fashion, but that doesn't seem to be the case.

    Like
  • Canadian here with an ongoing RBC issue as well.   Similar to what is noted above.  It started importing again, HOWEVER it labels all transactions as "inflow" instead of "outflow".  It creates a huge mess as they will not match to my manually entered transactions.  

    Like
  • I reported the issue to support again.  I agree...it's very frustrating to have to change my banking password almost every time I log in.

    Like
  • Don't waste your time trying to get YNAB to deal with this issue.  It is not worth your time to report it to YNAB - they know full well.  It has been going on for some time, they are aware of it. Same with many other financial institutions.  None of my accounts link, and they all used to.  Just decide how long you will choose to continue to use YNAB if you have to manually enter everything all of the time.....

    Like
  • I tried this morning and I received the same error. I changed my RBC password as Maroon Foal mentioned and it re-established connection.

    Like
  • Support changed my connections to their other import partner. I was able to connect, but no transactions appeared and I had to re-authorize every few hours. They are saying there is another widespread issue with RBC. Hopefully this will get fixed soon. For now, they advised me to do manual imports until things are fixed

    Like
  • Interesting - I also was able to connect after resetting my password.

    Like
  • I can also confirm that changing my password and reconnecting worked...

    Like
  • Any update on this?  My renewal is coming up and while I love YNAB, I need this functionality to work or I won't renew.

    Like
    • Pink Keyboard You should contact support. They'll look into your account and will fix it. Works for me every time and they respond quickly

      Like
    • Sky Blue Thunder (767daf21c896) 

      Thanks, I filled out the form, so hopefully it gets sorted.

      Like
  • I just tried connecting again. I was able to make a new connection and re-link, but we will see if it stays that way. I'll provide an update after this weekend to see if stays connected and imports transactions.

    Like
  • I worked with support to resolve it. They made some changes that finally fixed my connection and had it working great for about a solid week before they made one more change "to make it more stable" and this of course broke the connection and I was never able to get it working again for more than 12 hours.

     

    I seem to be able to make a connection and link the accounts but every night (when I assume it tries to sync accounts), something triggers a security issue with RBC and it triggers a "re-authorize" message on YNAB.

    Like
  • Just wanted to provide an update on my case with RBC.

    I was able to re-link everything a few days ago. I noticed during the linking process that some of the graphics/interface inside the little pop-up window looked different and that gave me some hope. I was able to link to RBC after a couple of tries, and it has stayed linked and syncing now for almost a week. Yesterday I received an e-mail from YNAB support saying the import partner had advised them a fix was in place and connections should be working.

    On the RBC end, the only change I made was to select "Ask me at least one PVQ each time I sign in" as I've had better luck with that option selected. It does mean you have to answer one of your security questions each time you log into RBC outside of YNAB but that's alright with me.

     

    All my other connections through YNAB are working well also - (Tangerine and EQ bank) so I have to give them kudos. Hopefully things stay running smooth for a while.

    Like
    • For me, after changing my RBC password, it worked for about a week. It then stopped working. A couple of days of waiting later, I changed my RBC password again and it's now working again. I'd probably rather not have to change my password once a week though...

      Like
  • Same as before, updates once after changing my RBC password then won't update again. Tried my normal ritual of logging in and changing my bank password, unlinking the accounts on YNAB, removing the account on YNAB then re-adding the account with the new password. This time it won't connect and I keep getting wrong username or password. Although cumbersome, there was a work around before. Seems like that is not working now. Yes, I submitted another ticket. By the timeline of information I have, RBC has not been linking properly for approximately 3 months now. On October 1, 2020 it had been 2 weeks since my account updated and this problem really started.

    Like 1
  • I haven't had a connection for 8 months now--- trying to work with YNAB again after a hiatus and this is beyond frustrating!!!

    Like
    • Gold Wizard  We're happy to help get this working for you! While we can't troubleshoot import issues on the Forum, our Direct Import team can assist when folks report a Bank Importing Issue. 

      In this case, our team will follow up via email with you. Thank you!

      Like
Replies are closed
Like4
  • 4 Likes
  • 5 mths agoLast active
  • 62Replies closed
  • 736Views
  • 31 Following