Citi Cards

Is it just me, or are others finding it difficult to maintain (or establish) connections with Citi credit cards?  I'm constantly getting the "Delayed Connection" with 2 Citi cards.  I'm still in the trial period and beginning to wonder if this will be a regular occurrence with YNAB?? I don't have this problem with other applications that connect to Citi.

79replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • We're closing out Bank Importing threads in the forum to make sure these issues are better resolved.

    Replies in this thread have been turned off, but if you’re having trouble with your bank, please fill out this form and our Direct Import team will help you get things back up and running! :)

    Like
  • Same here.  I switched from YNAB4 to the Web App pretty much for the direct-connect abilities.  My switch was about 3 weeks ago and I log in a few times per week.  Seems like every time I log in, I have the little wrench by Citi Cards showing delayed.  I am also a Bank of America user for checking/saving - and have seen that several times as well.

    Is this just the nature of the beast?  or are there known problems with these companies?

    It's frustrating because when I manually login to Citi or BofA - it works every time.  

    Like
  • I have to keep reverifying when it finally decides to update.

    Like
      • Jannelle
      • jannelle_ynabsupport
      • 1 yr ago
      • Reported - view

      Purple Kat Hmm, do you mean you have to authenticate a connection before you're able to import? For some banks and financial institutions (and their specific security protocols), this situation is expected. It's great for security of course, but not so great for direct import! 

      Let me know if you're ever unable to connect/import though, that's definitely not expected. 😊

      Like
    • Jannelle Citi Bank which manages my Best Buy credit card is the one I have to input the secondary verification most of the time. Even then it's a crap shoot on whether it actually connects.

      AND Citi/Best Buy is unavailable for downloads yet again.

      Like
    • Jannelle Can *not* connect. Used to connect fine. Tried everything suggested.

      Like 1
    • Hi wayne the insane !

      I see you've written into support! This appears to be a growing issue with Citi and our Direct Import partner is on the case! We'll reach out to you via email once they've given us an update! :)

      Like
    • Faness Thanks -- looking forward to getting this working again!

      Like
  • My citi and bank of america  connections have been solid for a while now.  I did have some old transactions import this week but that seems to have stopped.

    Like
      • Fireproof
      • Consultant
      • Lavender_Orca.3
      • 1 yr ago
      • Reported - view

      Herman Thanks for the feedback.  There is hope!  😊 

      Like
  • Hi Mark G. !

    I have a Citibank credit card that I  connected under the regular "Citibank" option, and I've never had those issues! Can you try connecting under that one and see if it works better for you? I'm very hopeful it will! 😊

    Like
    • Jannelle I just removed Best Buy/Citi and tried Citi. No go. And because it's in maintenance mode I can't reconnect with Best Buy/Citi, however, it did go through the secondary verification.

      Like
      • Jannelle
      • jannelle_ynabsupport
      • 1 yr ago
      • Reported - view

      Purple Kat For this one, I think our Direct Import partner will need to take a look! I'll followup from [email protected] so we can keep track of communicating back to you. 😊

      Like
  • I've just disconnected and reconnected the account (using the regular Citibank option as I did initially) and it seems to be working for the moment.  

    Like
    • Mark G. ...and it’s back. After disconnecting and reconnecting yesterday, things seemed to be working again.  But I have the frustrating yellow triangle for both Citi accounts again.

      Like
      • Jannelle
      • jannelle_ynabsupport
      • 1 yr ago
      • Reported - view

      Mark G. Hmm, it looks like you may still be connected under the "Citi - Credit Cards" option. Can you try connecting under the regular Citibank option instead?

       

       

       

      Here are the steps:

      --Select your budget name in the top left-hand corner and choose Manage Connections from the drop-down menu.

      --Click the ‘Remove' button next to the Citi - Credit Cards connection and click to confirm the removal. Then hit the ‘X’ when it’s finished being removed.

      --Clear your cache (or you can open up an "Incognito" or "Private" window and login to YNAB again to continue these instructions there.)

      --Hover over the account that needs to be reconnected (in the left sidebar), click on the edit icon, and select ‘Link Account'.

      --Click 'Add New Connection' and search for "Citibank" and follow the prompts to connect to the corresponding account.

       

      Let me know how it goes! If you still run into an issue, leave that connection as it is (even in the error state) and I will get this reported to our direct import partner and they can get to investigating! 

      Like
    • Jannelle I had already done everything you suggested (except clearing cache), and was about to do as suggested... but it's working again, so I'll leave it alone and see what happens.  Thank you!

      Like 1
    • Mark G. Yay for things being back up and running! :)

      If it gives you anymore trouble, just let us know!

      Like
    • Faness The "Delayed Connected" symbol is back again.  I'm going to try the steps recommended above and see what happens, but I gotta say... I'm not getting my hopes up. 

      Like
    • Mark G. It should kick back in for you! We're currently having trouble with Citi, but it's a duplicates issue (transactions are importing multiple times for some users), so you should still be able to connect. Let me know if it doesn't!

      Like
    • Faness as feared, the “Delayed Connection” error is back. I’ve performed the steps you recommended and it worked (as before) for about 12 hours, but it’s back again. 

      Like
    • Mark G. Drat! I was hoping it wouldn't come back, but no worries! I've asked our Direct Import partner to take a look at things and I've sent you an email with a few more details! 

      Like
  • Any clue as to when Citi and YNAB are going to play nice?

    Like
    • Purple Kat Sorry you're having trouble! Are you running into a connection error? Our Direct Import partner is working on ironing out issues with Citi transactions, but you should still be able to connect.

      Like
    • Faness  I keep getting the Maintenance message. I haven't been able to link it all weekend.

      Like
    • Purple Kat Just to confirm, it's the Best Buy card, supported through Citi, correct? I see our Direct Import partner is investigating your connection with that account so I want to make sure I'm not missing another one!

      Like
    • Faness  Yes it's the Best Buy Citi one that isn't working. I've included a screenshot from a moment ago.

      Like
    • Purple Kat Thank you for sending that along! We're keeping an eye on this and we'll let you know once our Direct Import partner sends us an update!

      Like 1
  • It has been absolutely terrible

    Like
    • Hi Sky Blue Cyborg !

      Are you having trouble with Citi? I took a look on our end and I'm seeing an error that usually gets cleared up by our Direct Import partner automatically, but it can take 48 hours to do so (or 72 if it happens to fall on a weekend). If you're still seeing this error after another day or so, can you let me know? At that point I'll have our Direct Import partner dig into this for you. :)

      Like
    • Faness The connection may be live now but it is down half the time.

      Like
    • Sky Blue  I posted a short summary of this issue below, but you since your accounts are connecting you should still see your transactions import within 48 hours of clearing your bank. Are you seeing a delay that lasts longer than that?

      Like
    • Faness Most of the time it takes about 24 hours but can take longer. It is more about the frequency that this happens. For instance, ALL of my accounts are delayed right now. This has happened several times this week. 

      Like
    • Sky Blue Cyborg Sorry for the delay! I took a look and those accounts are now showing as connected. I understand you're running into that Delayed status more frequently than you'd like, but as long as it's clearing out on its own pretty quickly, your accounts should stay in sync. 

      Like
  • I continue to get the delayed connection on a regular basis. The connection may work for a day or two, then the yellow triangle appears.  “Delayed” is the norm. 

    Like
    • Hi Mark G. !

      I checked and I see you've written into support about this issue. It sounds like a timing issue. When YNAB checks for transactions, the attempt can hit an error that essentially tells us to check back later. Our system does, but there can be a bit of a lag-time between when they complete a successful sync and you see that `Delayed` status turn to `Good`.

      Despite seeing the Delayed error, since Citi is successfully connecting, you should still see transactions import within the 48 hours of clearing your bank.

      Like
  • Hi, I have been having this same problem off and on for months. Every time I log into YNAB my Citi accounts show the exclamation mark. When I try to reconnect I get the "We're having trouble connecting error message." I tried follow the steps outline above regarding removing and reconnecting to the accounts, however, I have not been able to successfully re-establish a connection to any of my Citi accounts. 

    I am an avid YNAB user, however, I have to admit that this issue is beginning to cause me to rethink my continued use of YNAB. We recently switched to using our Citi credit card much more frequently which means that this issue is now a major headache as I have already spent several hours over the past couple of months all to no avail.

    Do you have any suggestions beyond the recommended steps of removing the accounts, logging out, clearing your cache, logging back in, and attempting to reconnect the account? This process has never been effective for me.

    Thanks!

    Like 2
    • Hi Pink Commander !

      Sorry for the trouble! The import provider your accounts are connected through, ran into an issue with Citibank. I just sent you an email and, if you're up for it, we can get you switched to another provider that shouldn't have the same issues! :)

      Like 1
    • Faness I'll take you up on that offer!

      Like
    • Green Sloth You beat me to the punch! I was going through the list here and you were up next! Email incoming! ;)

      Like
      • Gold Yeti
      • Gold_Yeti.1
      • 1 yr ago
      • Reported - view

      Faness I am having the same issue with Citi.  Can you help me to resolve it?

      Like
    • Gold Yeti I'd be more than happy to! :)

      It looks like you're also on the older provider. I'll send you a quick email so we can get you switched over, which should fix things!

      Like
    • Faness I don't mean to jump on this bandwagon, but I also am unable to connect to Citi for my Costco credit card.  Perhaps this is my issue too. (?)

      I have attempted clearing the cache, new browser sessions, and restarts with no luck.  I also tried a suggested from a separate thread to unlink and then re-link the account.  No luck there and now I am stuck with an unlinked account.  I am able to login directly to Citi so I know my credentials are valid. 

      Any suggestions would be appreciated.  Thank you.

      Like
    • Green Router I checked, and your accounts are connected through the affected Direct Import partner. I've just sent you a message about switching you over! :)

      Like
    • Faness I am having the same issue as well.  Am I affected by the old provider too?  Thanks for your help!

      Like
    • Hi Slate Gray Barnacle ! Sorry for the delay! It looks like that was the case and Kody was able to get you switched over. If you're still having trouble, please let us know! :)

      Like
    • Faness I consistently have issues connecting with Citi also. Will you please check if I need the provider switch as well? TIA

      Like
    • Hi Gold Falcon !

      I took a look and you're not on the same provider that was having issues, but you're not on the newest provider either. Can you give the troubleshooting steps a quick try?

      To start, you’ll remove the connection to this financial institution:

      1. Select your budget name in the top left-hand corner and choose Manage Connections from the drop-down menu.
      2. Then Remove the connection(s) to this financial institution, confirm removal and close the window.

      Then you’ll reconnect your account(s) to a fresh connection:

      3. Hover over the existing account(in the left sidebar) and click on the edit icon. 
      4. Select Link Account > Add New Connection. Search for the financial institution, and follow the prompts.

      If that doesn't do the trick, let me know and we can get you switched over! :)
       

      Like
    • Faness No ma'am it did not. I still get the "we're having trouble connecting to your financial institution" pop up. 

      Like
    • Gold Falcon I just sent you an email so we can give the other connection a try! :)

      Like
    • Faness same issue as well connecting to Citi. Can you help? 

      Like
    • Hi Silver Cyborg ! I'm sorry that you're having trouble! You're not the only one running into this. We've reported it to our Direct Import partner, and they're investigating the issue. I've reached out from [email protected], so we can get back to you with any updates!
       

      Like
    • Nicole at YNAB Hi can you check to see if the Direct Import partner partner i am using is causing me these same issues with my Citi account?  Thank you

      Like
    • Hi Forest Green Lion !

      I took a look and I'm now seeing a successful connection to Citi, but no recent imports. If you still aren't seeing transactions import by this evening or tomorrow, can you let me know?

      Like
    • Faness Thank you.  They did import today.

      Like 2
  • I've been having the same issue for the last week. It's happened a couple of times, but unlinking and linking usually works. This time, it just won't find it. I think YNAB needs to update the link to https://online.citi.com/US/login.do , which is currently not listed.

    Like
  • I have three budgets set up. Two of the budgets have a Citi/Costco credit card, each card has a different username/login with Citi. I was able to connect one of the accounts but I can't connect the second. The error it gives me is the that Citi doesn't recognize the login info. However, it works when I log directly into Citi. I have tried all of the steps from the main post above but to no avail. I have been trying to get the account to link for about 4-5 days with no luck. I sent an a few days ago with an automatic message that I should get a response in 24 hours. No response received so far. Can you help me? Without direct import, using the app is cumbersome. Thank you!

    Like
    • Hi Melanie Avery !

      Sorry for the delay! I took a look and it seems Michele beat me to the punch! :)

      You can respond back to the email she sent you and we'll go from there!

      Like
  • I continue to have problems maintaining a connection with Citi - please switch my account to the newest (hopefully reliable) provider.  

    Like
    • Hi Mark G. ! 

      I just took a look and you're already connected through our newest Direct Import partner. I took a look and I'm seeing a Delayed error for your Citi account. Our Direct Import partner tries to sync with each of your connections daily. But it's not uncommon for any financial institution to say, "Sorry, check back later—we're busy!". This is what triggers the Delayed error to show up on your end.

      Then our provider does exactly as the financial institution asks and automatically checks back later. When they do, everything syncs up ok and all is well. Except this (here's where it gets a little hard to explain) — there's a bit of a lag-time between when they complete a successful sync and you see that `Delayed` status turn to `Good`.

      It has to do with a time restriction put on YNAB that says we can't try to contact your financial institution again until 8 hours after our Direct Import partner completes a successful sync. It's a bit difficult to explain, but it basically prevents us from checking in with a bank too many times and triggering their security alerts or getting you locked out of your account.

      So even though you may be seeing `Delayed`, our Direct Import partner is either queued up to try again later or has already completed a successful sync and we just need to wait 8 hours until we can update the status. 

      My question for you is this — are you finding that transactions are still becoming available for you to import? But maybe just on a delay? If so, then that definitely would indicate that the 'Delayed' errors aren't sticking around for long (even though they may appear to from your vantage point).

      Those errors should clear up within 48 hours (72 hours on weekends), but if you're still having trouble after that, let me know and we can have our Direct Import partner investigate!

      Like
  • I'm having the same issue.  Very inconsistent with Citi.  Can you check mine?

    Like
    • Hi Orchid Battery !

      I took a look and I'm currently seeing a successful Citi connection through our newest Direct Import partner. You may be seeing a delay, as described above, but you should still be seeing those transactions import.

      Like
  • No transactions since 10/30.    There should be transactions from 10/31, 11/1, 11/2....

    Like
      • Jannelle
      • jannelle_ynabsupport
      • 1 yr ago
      • Reported - view

      Orchid Battery It looks like you're hitting an error on that Citi - Credit Cards connection, which explains why those transactions aren't importing! 

      I mentioned it earlier in this thread, but I have a Citibank credit card that I  connected under the regular "Citibank" option, and I've never had an issue with a "Delayed" error. If you're up for it, try connecting under that one and see if it works better for you? I'm very hopeful it will! 😊

       

      If that doesn't do the trick, we will get our Direct Import partners eyes on this! 

      Like
    • Jannelle  what exactly do I need to change?

      Like
    • Hi Orchid Battery !

      Sorry for the delay here! You can change which direct import option your Citi bank account is connected through. To do this, hover over the name of your Citi account and click on the edit icon that appears, then click on Unlink account - that disconnects your account from the current Citi option you've selected. Then, click the edit icon again and select Link Account. On that screen, scroll to the bottom and select "Add New Connection". Instead of "Citi - Credit Cards" select "CitiBank".

      If that doesn't get you up and running, please let us know! :)

      Like
  • I'm a new user and having Citi troubles as well. I'm still in my trial period and this is pretty crucial to me in order to sign on. I have both a Citi Costco card and a Citi Doublecash card. I've tried disconnecting and making sure I picked just the "Citibank" option, even verifying that the login URL it showed was what I use when manually logging in. Same problem. I'll try again during the week over the next few days, but I gotta say this is pretty discouraging.

    Like
    • Turquoise Sander I have the same cards... and the same issue.  This has been the case ever since I signed up.  Regrettably, I've found that I just have to accept that this is an unreliable connection.  I maintain that my subscription should be pro-rated such that I only pay for the time that it is working 100%.

      Like
    • Hi Turquoise Sander !

      Sorry for the trouble! I took a look and I'm seeing an error that usually gets cleared up by our Direct Import partner automatically, but it can take 48 hours to do so (or 72 if it happens to fall on a weekend). If you're still seeing this error after another day or so, can you let me know? At that point I'll have our Direct Import partner dig into this for you! :)

      Like
  • I am also having issues with my Citi Credit card importing.  Tried unlink and setting up again, still no go.

    Like
    • Hi Chris T !

      I know you mentioned unlinking the account, but have you tried removing and then readding the connection? I'm seeing an error that's usually solved by doing that.

      To start, you’ll remove the connection to this financial institution:

      1. Select your budget name in the top left-hand corner and choose Manage Connections from the drop-down menu.
      2. Then Remove the connection(s) to this financial institution, confirm removal and close the window.

      Then you’ll reconnect your account(s) to a fresh connection:

      3. Hover over the existing account(in the left sidebar) and click on the edit icon. 
      4. Select Link Account > Add New Connection. Search for the financial institution, and follow the prompts.

      If that doesn't do the trick, let me know and we'll go from there! :)

      Like
  • That’s exactly what I did.  Still no good.  It’s acting like it’s the wrong username and password, but I know it’s correct.

    Like
    • Chris T Thank you for letting me know! I'm going to reach out via email so we can try another option! :)

      Like
  • I also started having issues with my Citibank credit card.  I have tried removing and readding the account as well.

    Like
    • Gold Yeti Thanks for trying those troubleshooting steps! I've asked our Direct Import partner to take a look at your account connection and I've sent you an email with a few more details! :)

      Like
  • I'm also having problems importing from Citi.  It's been about two weeks and the username/password won't connect, even though I know they are correct.  I've tried disconnecting and reconnecting the account but it isn't working.

    Like
    • Hi Navy Blue Wizard !

      Our Direct Import partner let us know that this is a wide-spread issue. They're currently working on fixing the integration with Citibank to get direct import back up and running. You can keep an eye on our status page for updates! :)

      Like
  • I'm also on the trial, and pretty much every other day it says the connection is delayed.

     

    The Citi card is my primary credit card, so this is really frustrating as I'm kind of OCD about checking for new transactions to import.

     

    Does YNAB know if this is a situation unique to Citi?  My Amazon card and Chase credit cards don't seem to have this issue at all.  In my experience, the Amazon card seems to be the fastest at adding new transactions.

    Like
    • Hi Powder Blue Piccolo !

      Currently, we're seeing a rise in Delayed transactions from Citibank due to a widespread issue. Our Direct Import partner is currently working on a fix, but they aren't able to tell us just how long before it's back up and running. In the meantime, you can give File Based Importing a try to keep your accounts up to date! :)

      Like 1
Replies are closed
Like
  • 1 mth agoLast active
  • 79Replies closed
  • 1709Views
  • 24 Following