New transaction entry screen doesn't recognize smart keyboard right away

The new transaction entry pop-up in YNAB 2.1 does not recognize when the iPad Pro Smart Keyboard is being used. You have to tap the amount entry area twice to get it to work.

To reproduce:

  1. Make sure iPad Pro is docked in Smart Keyboard
  2. Click on the "+ Trasnsaction" button, new transaction entry window appears
  3. Try to type your transaction amount on the Smart Keyboard; no joy
  4. Tap in the amount area, on-screen keypad goes away, keyboard still doesn't work
  5. Tap the amount again, on-screen keypad returns, and hardware keyboard now works
2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Pitot Tube ,

    Thanks for the thorough explanation and repro steps here! I'm sorry you've run into that (we don't like duplicating steps either!). We'll take a look at what we can do about this one and I'll post an update here soon.

    Thanks again for the heads up on this!

    -Elena

    Reply Like
  • Hi again Pitot Tube ,

    Good news: we've released version 2.2 of our iOS app and this issue is fixed in that new version! 🎉

    If you don't see YNAB as an available update yet in the App Store, search for it and download the new version that way. Thank you for your patience as we worked on this one!

    -Elena

    Reply Like 1
Like Follow
  • Status Fixed
  • 6 mths agoLast active
  • 2Replies
  • 416Views
  • 2 Following