Fidelity BrokerageLink Not Showing up

I have a Fidelity 401k that I am trying to link with YNAB. In Fidelity the account is a "BrokerageLink" account so for my current employer I have two accounts, a typical 401k that shows up in the YNAB prompt to link accounts, and the BrokerageLink account where funds can move (automatically) from the regular 401k to this account. The later is the account that doesn't even show up when adding Fidelity as an institution (both regular Fidelity and NetBenefits).


Has anyone run into this issue or know how to fix it?

20replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Steel Blue Rhythm !

    I took a look and I'm seeing two separate Fidelity connections and multiple accounts. Are none of them the specific account you're looking for? If not, can you let me know the URL of the website where you log in to access that Brokerage Link account? There are several Fidelity options to connect to, so I want to make sure we're looking at the right one. :)

    Reply Like
  • Correct, none of the the accounts showing up for either Fidelity connections are the BrokerageLink account. 
    When I want to log in to that account I do so thru

    Reply Like
    • Steel Blue Rhythm I need just a few more details to get this reported to our Direct Import partner so I'm going to reach out to you via email! :)

      Reply Like
  • I have the same issue. I can access the 401(k) that has a BrokerageLink sub account via either or (though I suspect the latter is more technically correct). Is there any other information I can provide as an additional data point?

    Reply Like 1
    •  Faness sorry, I tagged the wrong person

      (If you can actually look at our account to debug the issue, my 401(k) - the one with the brokerage link stuff - is the one that YNAB currently claims only has $0.87 in it)

      Reply Like
    • Hi Slate Blue Rhythm !

      No need to apologize! I'm more than happy to take a look! :)

      Our Direct Import partner let us know that the BrokerageLink account should be available under the "Fidelity Investments (Advisor)" connection option. When you have a moment, can you try adding that connection to your budget? If you still aren't seeing the BrokerageLink account, let me know and they'll troubleshoot adding it there.

      Reply Like
    • Faness Unfortunately, it looks like it's not going to be quite that easy. The Fidelity Investments (Advisor) connection option informs me that the credentials are unrecognized.

      Reply Like
      • Jannelle
      • jannelle_ynabsupport
      • 10 mths ago
      • Reported - view

      Slate Blue Rhythm I hope you don't mind if I jump in for Faness! Hmm, I'm seeing quite a few options that our Direct Import partner suggested, would you mind giving all of them a shot? Fidelity can be quite a messy one, but we will get to the bottom of it! 😆

      Reply Like
    • Jannelle Not at all, and you weren't kidding about there being a bazillion Fidelity options! After playing with YNAB a few days, though, I think we've decided that we don't even want to link the retirement accounts... As far as we're concerned, the money doesn't exist until we're 65, so having it visible as "current" equity is more confusing than it's worth. Thanks for working with us on it, though! :)

      Reply Like 1
    • Slate Blue Rhythm I completely agree on that approach! However, if you ever change your mind, don't hesitate to let us know and we can work on getting things straightened out! :)

      Reply Like
  • Faness or Jannelle - Hoping you can help re-open this issue with me. I, too, am attempting to add my Brokeragelink account through Fidelity. I've exhausted all of the "Fidelity" options in the account connection with no luck. 

    Reply Like
    • Hi You Need A Biscuit !

      I took a look and the BrokerageLink should connect under the Fidelity Investments (Advisor) option you added, however, I'm seeing a password error.

      Here are some things you can try that typically help resolve this issue:

      — Check to make sure the URL you use to log into your online banking account matches the URL you see in YNAB.

      — Double check to make sure you're entering the correct credentials. If you’re using a password manager, try entering your login credentials in manually.

      — If your password is longer than 32 characters, try shortening it.

      — Log into your financial institution's online banking account, then immediately try reconnecting the account in YNAB.

      — Make sure your password doesn't contain any of these characters: 


      - Pipe: |

      - Tilde: ~

      - Less Than: <

      - More Than: >

      - Ampersand: &

      If that doesn't do the trick, let me know and we'll have our Direct Import partner dive in! :)

      Reply Like
    • Faness Thanks! Unfortunately this is not resolving the issue. The password error with the Fidelity Investments (Advisor) option is because I don't have an account with this arm of Fidelity. The login information I use to access my BrokerageLink account is the same I use to access another one of my accounts at Fidelity, which is correctly showing up.

      BrokerageLink accounts are investor-directed accounts that are part of Fidelity's NetBenefits accounts. However, when I attempt to add that account, I only see the small amount of money in transit before it enters the BrokerageLink account. See the screenshot from my Fidelity account access for details. I can successfully add the first two accounts to YNAB, but not the last one (the BrokerageLink account).

      Reply Like
    • Hi You Need A Biscuit !

      Thanks for giving those steps a try! I've gone ahead reported this missing account to our Direct Import partner. I've sent you an email with more details, and I'll follow up there when we hear back!

      Reply Like
    • You Need A Biscuit did your brokerage link issue ever get solved?  Trying to navigate the same problem

      Reply Like
    • Spring Green Wildebeest I'm happy to help with that! I sent you a quick email, so we can dive in. 🙂

      Reply Like
  • I have the same issue.  I've tried both Fidelity logins to no avail.  I thoguht I'd mention it as still being an issue for people.  It's the only one that doesn't work!  Funny enough, I can get my HELOC to work where Quicken can't but Quicken can get my 401K Brokerage where YNAB can't.  Go figure :)  I can't fully switch from Quicken until this is resolved.  Thanks!

    Reply Like
    • PedalMonk I’m happy to help! Were you able to get connected? I'm seeing a successful connection to Fidelity NetBenefits on our end. Let me know and we'll go from there!

      Reply Like
      • PedalMonk
      • Violet_Rhythm.7
      • 3 mths ago
      • Reported - view

      Nicole Hi Nicole, NetBenefits connection works fine.  Within NetBenefits there are two accounts.  401K and 401K BrokerageLink.  It's the 401K BrokerageLink that doesn't show up.  Everyone in this thread is having the same issue.  So the connection works, but doesn't show the "BrokerageLink" portion of NetBenefits account.

      I know it CAN work because it works in Quicken.  Honestly, this sounds like something that needs to be resolved behind the scenes.  Thanks for your help :)

      Reply Like
    • PedalMonk Thanks for those details! We work with a few different import partners, so it looks like the situations are the same—but can be a bit different on the back end! Can you add a new connection to Fidelity? That's where the BrokerageLink account will get pulled in.

      Since you didn't see it there, I'm going to reach out via email to gather more information and have our import partner look closer!

      Reply Like
Like3 Follow
  • 4 wk agoLast active
  • 20Replies
  • 365Views
  • 10 Following