Can't add TD Ameritrade accounts

I want to add my TD Ameritrade accounts the login with User ID and password works fine but then there is no security question inquiry. Instead a empty account page is shown with nothing to select except for the back button.
Prior to performing a fresh start and deleting every account, then re-adding all the accounts the import of TD Ameritrade worked.
I guess the fresh start and  deleting of the accounts broke something in the database and it won't let me add TD Ameritrade anymore. Or might that be a precaution of TD Ameritrade to not allow YNAB to access the accounts a second time?

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • We're closing out Bank Importing threads in the forum to make sure these issues are better resolved.

    Replies in this thread have been turned off, but if you’re having trouble with your bank, please fill out this form and our Direct Import team will help you get things back up and running! :)

    Like
  • Hi Powder Blue Deer ,

    Have you already tried our troubleshooting steps? More specifically, have you tried to “remove” the connection (not the account!) and then re-connect? It's different than using the Disconnect button, you won't lose any data, and it seems to do the trick for most issues! 

    Here’s a video to walk you through the steps. If you’ve already tried this, or if you get to the end and you still can’t get connected, send us a note at [email protected] – make sure to mention the name of your financial institution and the URL you use to log in to their website directly.

    I hope that helps! 

    -Elena

    Like
Replies are closed
Like
  • Status Answered
  • 4 mths agoLast active
  • 2Replies closed
  • 730Views
  • 3 Following