YNAB keeps importing the same transactions

Hi! Been using YNAB for over a year now and haven't run into this problem before. After visiting NYC recently YNAB continues to import several of the same transactions over and over again, despite me having already approved them the first time they appeared and regardless of if I re-accept, reject or delete them when they get re-imported. I've tried disconnecting and reconnecting my account but then it happened again.

The screenshot is the second time it happened after reconnecting. As you can see the same transaction was imported twice at the same time.

Anything else I can try to fix this? I really don't want to have to delete these over and over again. Thanks!

9replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • We're closing out Bank Importing threads in the forum to make sure these issues are better resolved.

    Replies in this thread have been turned off, but if you’re having trouble with your bank, please fill out this form and our Direct Import team will help you get things back up and running!

    Like
  • I'm having the exact same problem, but with only 1 transaction. It imports multiple times sometimes, other times only once. But it's always the same one and one that already exists. Let me know if you find answers.

    Like
      • hew2702
      • hew2702
      • 4 mths ago
      • Reported - view

      pmosh I will for sure update if I find any solution! Glad I'm not the only one.

      Like
  • I'm having the same issue.  It has been happening for the last couple of weeks.  It is only happening with transactions from one vendor.  This vendor (a cruise ship) legitimately charged me about 12 times for gratuity at $30 each.  Even though the original 12 transactions went through to YNAB, YNAB keeps pulling old transactions over and over even though they have already been imported.  My guess is that the transactions are so similar to each other, YNAB is getting confused whether they have been imported or not. 

    Like
      • hew2702
      • hew2702
      • 4 mths ago
      • Reported - view

      Tomato Beat Yeah I thought about the similarity, too, but I've had many other identical transactions that haven't done it. Weird.... Hope I can find an answer!

      Like
  • Hi hew2702 , pmosh & Tomato Beat !

    We've heard from some other folks who keep seeing the same transactions show back up again...and again...and... again. We're on the case! 🧐

    You can select all the transactions you don't want to keep using the checkboxes on the left (to select all, use the top checkbox), and then click Edit > Reject to remove the transactions from your register. Once the duplicates are removed, they shouldn't import again.

    To make extra sure, the trick is to reconcile your account. After that, only transactions that cleared within the last three days will be available to import.

    If you start to notice anything else that you think might help squash this, let us know. 

    Like
  • Nicole For me rejecting the transactions didn't work- they'd just show back up again on a future import. However, the reconcile button did the trick. I haven't seen it come back up since pressing it.

    Like 2
  • The reconcile button seemed to work for me as well.

    Like 2
  • I never got around to reconciling the accounts but it sounds like it worked for others. The issue seems to have gone away now. Thanks for your responses!

    Like 2
Replies are closed
Like
  • Status Answered
  • 1 mth agoLast active
  • 9Replies closed
  • 55Views
  • 4 Following