Issues Linking to Discover

Has the switch to Plaid finally fixed the issue with linking to Discover?

I re-entered my credentials in YNAB when the transition to Plaid first happened, but then Discover notified me my account was locked out and I had to call their fraud department to verify my identity and request a password reset.  This happened minutes after connecting with Plaid, so I have to assume that's what triggered the alert.

I don't want to try it again unless others are actually having success.

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Discover is generally working well on Plaid, but if you're having any issues connecting, please get in touch with support!

    Like
  • I had issues with Discover too.  Sometime after I linked to Discover I had changed my Discover login ID.   importing still worked fine.  It wasn't until they switched to PLAID that it broke.  The error kept telling me to use the original user ID, which was pointless as that ID no longer existed.

    I had to create new Discover accounts (credit card and savings) then link those.  It worked fine and I haven't had any issues since.

    Like
  • I had the same problems and just unlinked the accounts for awhile. After having some success (I think) working with support on some issues with my other accounts, I decided to try and relink it. I haven't gotten the fraud alerts again this time (thank god!) and everything seems to be pretty smooth. The connections have maintained just fine for a few days, but transaction importing is still lagging - more than 24 hrs between imports. Gonna cross my fingers that some of that is just the weekend, and this gets better. 

    Like
Like Follow
  • yesterdayLast active
  • 3Replies
  • 36Views
  • 4 Following