API. Why can't I create a transaction before 2014-09-04?

I use your API to transfer data from another application. But I saw such a feature in your API. Can't create a transaction previously 2014-09-04. If the transaction is later than this date, the transaction is created. But manually I can create transaction.

{
    "transactions": [
        {
            "account_id": "[account_guid]",
            "date": "2014-09-03",
            "amount": 10000,
            "payee_id": null,
            "category_id": null,
            "cleared": "Cleared",
            "approved": true,
            "memo": ""
        }
    ]
}
1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Alexandr Gorodiolov  You should be seeing a 400 error with the message "must not be in the future or over 5 years ago".  Can I ask the purpose that you were trying to use the API for to create that old of transactions? 

    Reply Like
Like Follow
  • 2 mths agoLast active
  • 1Replies
  • 47Views
  • 2 Following