suddenly cannot open budget on phone

We've  been using YNAB on 5 devices for 3 years without any problems. Suddenly, it won't open on my phone. The problem happened after it tried unsuccessfully to re-sync.  Same thing happened to my husband on his IPad a few months ago and he hasn't been able to access YNAB since on that device.  Any idea what's wrong?

16replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Have you tried deleting and reinstalling the app? Sometimes that works.

  • Hi Violet Filly !

    Are you trying to access YNAB 4 (the older, desktop program) or the new, online version of YNAB? I want to double-check before troubleshooting because the two use separate mobile apps. YNAB 4 uses the YNAB Classic app while the new YNAB uses the YNAB app.

    Let me know and we'll go from there! :)

    • We use the YNAB 4 Classic. As suggested, this morning my husband deleted the app from his iPad and then tried to reinstall it.  He got a message saying "Woops! It doesn't look like you have any budgets set up for Cloud Sync. Have you set up Cloud Sync on the Desktop? Are you signed into the same Dropbox account?"  I'm afraid to delete the app from my phone and make things worse.

    • When I try to open the YNAB app on my phone I get a message saying "Import failed. The last import did not finish. Please import your data again."  (On my phone the whole problem started when I tried to put in a transaction while away from home. It said it had to re-sync, but then it got stuck and, I guess, never finished.)  Anyway, so then I click "OK" and nothing happens. I guess I don't know how to import data again. So then, I go to the menu bar in the upper left corner and click on my budget and get a message that says "Budget could not be opened."

  • Problem solved, thanks to tech support from a friend. Had to do with dropbox syching.

    Like 1
    • Violet Filly Sorry for not responding! When responding, if you mention me in a comment it comes directly to me so I know you've responded. :)

      Happy to hear you were able to get it ironed out!

      • the.zents
      • Tomato_Horse
      • 2 yrs ago
      • Reported - view

      Violet Filly So it looks like we are having the exact same problem as you on my wife's iPhone, "budget cannot be opened", "import failed", etc... (it works fine on my android)... could you describe the help that you got with your dropbox synching? Same as you, we had used ynab on multiple devices for years then all of a sudden, not working...

  • Yikes! I'm so sorry. I totally cannot remember what we did. It had to do with Dropbox.  Whatever we did fixed it on both my phone and my husband's iPad and now YNAB thinks we are new to the program. We keep getting beginner emails.  Since I am technologically challenged I mostly just stumble through and then can't remember what I did. 

  • I also have this problem with YNAB Classic - "import failed" - on opening up the app on either my iPhone or iPad. I use DropBox for cloud syncing. I can only update my budget with my Mac now.

    There is no information given in this thread which has helped me solve the problem. DropBox is up-to-date and I can access the files on my iPhone using the DropBox app. While the problem may be related to DropBox the access problem appears specific to YNAB. Has anyone else come up with a recipe for resolving this?

      • Jannelle
      • jannelle_ynabsupport
      • 2 yrs ago
      • Reported - view

      Pink Sound I am so sorry for the delayed response here! 


      Let’s kick this back to the beginning. Some of this may feel redundant to things you have already tried, but the sequence is important.

      First, if you have a significant number of transactions on your phone that have not synced to your computer, please let us know. They could be lost if you run through these steps — the desktop version may overwrite the mobile version of the data.

      1. Delete both YNAB and the Dropbox app from your phone. (If Dropbox was pre-installed, and you can't delete it, just disable it).

      2. On your desktop version of YNAB, double-check that Cloud Sync is activated under YNAB > Preferences. Make a note of the file path under Cloud Sync.

      3. Also check that Cloud Sync is enabled for this particular budget under File > Budget Properties.

      4. On your desktop version of YNAB, click File > Save a Version.

      5. Then click File > Load Another Version, selecting the time at the top of the list.

      6. Make sure Dropbox is syncing, and give it time to finish. Depending on the file size, this may take longer than you expect!

      7. Reinstall/enable Dropbox on your phone, making sure it is the same account (using the same email address) connected on your desktop. If you're not sure which account you're using on the computer, click the Dropbox icon in your tray, then the gear icon, then Preferences. The Account tab will show you the email address.

      8. Reinstall YNAB Classic on your phone. You’ll need to go to your Purchases page (iOS) or your Library (Android) to re-download. 

      9. Select Link Dropbox and follow the prompts to select your budget. You may have budgets with similar names, so be sure to select the right one!


      That should do it for you, let me know how it goes!

  • Thanks Janelle. This process solved the problem on my iPhone (5) but not my iPad (gen 2). Will not pursue using the iPad for YNAB Classic any longer as my phone now works for on-the-go budget updates.

    Like 1
  • Hi  Jannelle ! Glad to see this thread, we’re having the same issue but with the new YNAB, no Dropbox should be involved. We got a new iPad, downloaded the app, logged in, and selected our budget to open.  We then got an error that the budget could not be loaded.  Any advice?  Internet connection is fine so shouldn’t be the problem. 


      • Ben
      • Toolkit for YNAB Designer & Developer
      • furiousfalcon
      • 2 yrs ago
      • 1
      • Reported - view

      KarlynD Two quick things to try: try force quitting the app and reopening. Also maybe try deleting the app from your phone and re-downloading?

      I imagine YNAB forum support should be by soon to help, but you can also email [email protected] if you don't get it figured out.

      Like 1
    • Hi KarlynD !

      Ben's suggestions are a great place to start! If they don't fix the issue, can you post a screenshot of the error you're seeing? You can also submit a Bug Report and our development team will take a look at things for you! :)

  • Thanks Ben and  Faness !

    That worked!  Classic... we had tried both of those things before writing in to the forum, and for some reason didn't have luck the first time. Second time's a charm... I force quit and then deleted the app and re-installed. It then allowed me to download the correct budget.  Thanks for the magic. :) 

    Like 1
    • KarlynD Things always work better after you tell on them. ;)

Like Follow
  • Status Answered
  • 2 yrs agoLast active
  • 16Replies
  • 2356Views
  • 7 Following