Issue with payee search on Android

When adding a new transaction and searching for a payee, if I type in "wal" to filter the list, on the web app I get a list which shows payees starting with "wal" first, then payees that contain "wal"  The IOS app also behaves this way.  


In the Android app I get a very different list, it appears to include anything that contains "wal" in alphabetical order, which definitely produces some unwanted results, as you can see below:


Transfer accounts also show up first on Android for some reason, where on the web app and IOS they always show at the bottom.  What I wanted below was "Home Depot" which would have been first in the list on the web app, but ends up being quite a bit further down in Android:



Additionally, the list is needlessly grouped by letter, which just takes up more space, causing unnecessary scrolling down to find the entry you want.

7replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hey Cyan Koala ! I'm going to move this over to the Budgeting on Mobile section.

    On Android, transfer payees are in a section labeled Transfer Accounts. So it looks like the ATM Withdrawal is the first alphabetical result.

    I did some testing and found certain inputs showed the same results on iOS/Android/web app as you mentioned: payees starting with, then contains, alphabetically. Then varying results based on if a payee has location data (mobile only), or a transfer payee.

    I've reached out to a colleague to clarify a few things, and will follow up when I hear back!

    Like 1
  • Thanks for the response.  That is definitely not the behavior I'm seeing - on Android mobile, I am getting results that contain the search phrase, in alphabetical order.  When I type in "Bur" hoping to get "Burger King" instead I get "Auburn Spirits" as the first result.

    My device is a Galaxy S10e if that helps, Android 10, and I'm on the latest version of the YNAB app from the Play store.

    I posted this in the /r/YNAB subreddit as well, at least one other mentioned the same issue

    • Cyan Koala Sorry for the delay here! Our bug squashing team would love to dig in, and look closer at what's going on. Can you fill out a Bug Report? Make sure to include the version of the app that you're using, your device, and OS version. They'll go from there!

  • Interesting, I didn't even know I could search for transactions in the app, but thanks for mentioning it. I tried it on my Android app, (running Pie on a Motorola G7 Power), and it seemed to work correctly. Maybe its one of those mysterious yet all too common Android compatibility issues. If only my Fitbit app worked as smoothly as YNAB on my phone I'd be very pleased lol.

      • Cyan Koala
      • Cyan_Koala.4
      • 1 yr ago
      • Reported - view

      Silver Inspector My issue is searching for payees when entering a transaction, not searching transaction history.  When searching transaction history, I think the results are always just listed by date in descending order.

    • Cyan Koala interesting... I tried that and it seemed to work. I'd suggest trying what seems to work for most misbehaving Android apps, which is start by heading into settings>applications, find the YNAB app, click on it then drill down to storage. Try flushing the cache, (no pun intended), and see if that works and then if it doesn't, try uninstalling and reinstalling the app.

      • Cyan Koala
      • Cyan_Koala.4
      • 11 mths ago
      • Reported - view

      Silver Inspector uninstalled and reinstalled, still same behavior.  Your screenshot doesn't show any payees that contain "Wal" maybe you just don't have any?  Try adding a payee named "A Walmart" or "B Walmart" and perform the same search, you should see what I mean.  

Like Follow
  • 11 mths agoLast active
  • 7Replies
  • 64Views
  • 2 Following