Scheduled Transactions populating early

I've had this problem several times in the last 30-60 days, and I think I have finally found a common thread so I can report it coherently.  Sometimes when I open my budget I see monthly recurring transactions showing up as "black" not "grey" much too early.  It's happened with 90-180 days worth of transactions each time.  I also see a large number (30+) of notifications in the little orange circle on the app icon on my phone's home-screen.

I primarily work my YNAB budget from Chrome on a PC, but also use the android app on my Galaxy S7 (Samsung-SM-G930A running android 8.0.0).  I live in the US, central time zone and have the automatic date and time turned OFF on my mobile.  

The common thread I've discovered is that it happens when I have to reboot my phone.    I've gone back into my budget each time, deleting the future entries, and re-establishing the recurring nature from the last real transaction, but this is quite tiring.  

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • when you reboot, it may be setting to a default date?  I know you can force future dated transactions into the register by setting the date in the future.  

    Reply Like
  • Hi Forest Green Stallion ,

    I'm so glad you wrote in about this – we are currently investigating this issue in a big way!

    We've also narrowed it down to an Android reboot and time zone situation – great sleuthing on your part here! 🔍

    I'll post here when we have an update on this one, and there is something that could help in the meantime:

    If you see this happen again it would help a ton if you could send us your budget with the logs as soon as possible after you see those future-dated transactions post.


    Here's how to do that:

     - Tap the “Settings” icon in the lower right 
     - Select “Get Help"
     - Include a brief message indicating you are sending logs as requested. - Tap the send icon in the upper right corner.

    Let me know when you've sent in that message so I can look for it. 

    We will get this figured out!


    Reply Like
  • Hi there Forest Green Stallion !

    I'm writing to let you know that we've fixed the underlying issue that caused those scheduled transactions to post incorrectly in your budget.

    Update your Android app to the most recent version (v.5.4.3) and you'll have the fix.

    Thank you for your patience as we got this one figured out!


    Reply Like
Like Follow
  • Status Fixed
  • 2 mths agoLast active
  • 3Replies
  • 216Views
  • 4 Following