Bank of America Connection Issue

For the past two days I haven't been able to connect to my bank of america accounts. I can log in via my bank's website normally, and I checked the status page, however my issue is not with the "finicity_add_accounts_session" field as indicated. I just get a: 

I've also tried removing the connection and readding.

50replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Coral Yeti !

    Thanks for reaching out about this! Since those troubleshooting steps didn't do the trick, it's time for our Direct Import partner to investigate! It may take them some time to figure out what's going on, but they are usually able to resolve many Direct Import issues within a week or so—I will get back to you when I hear anything actionable. 

    While they're looking under the hood, please don't "remove” the BofA connection and cause it to disappear on them. :)

    To keep everything up to speed, enter transactions on the go with the mobile app and/or try out File-Based Importing in the web app—a super quick and easy alternative to direct import and manual entry! It allows you to drag and drop a file containing your transactions right into YNAB.

    Let me know if you have any questions. :) 

    Reply Like
  • Same here.  It's been working great for the past year and a half but I haven't been able to get YNAB to connect to Bank of America for the past few days.  I keep getting the error:

    The answers to your authentication questions were not recognized or the connection timed out. Please try again.

    But I know the password is correct -- I use it to log in to the BOA website every day.

    Reply Like
    • Budgeting Dad Alrighty, I'm on it! Our Direct Import partner is looking into your issue with BofA too! 

      As for those transactions, once Direct Import starts working again, transactions importing with the same date & amount will be skipped to avoid duplicates. :)

      Reply Like
  • same problem here.  can't connect to BofA.  login works fine from web.

    Reply Like
    • Hi Sea Green Piano !

      I took a look but I'm seeing a successful connection to Bank of America and then an error for Bank of America (CA). If you're able to connect to Bank of America, and your accounts are listed there, you should be good to go! If the (CA) specific account is a separate account, let me know and we can take another look! :)

      Reply Like
    • Faness Correct, it is BofA (CA) that I've always used, and now cannot connect.

      Reply Like
    • Sea Green Piano I tried refreshing that connection but it gave me the same error. I'd like to try another approach to fix that connection. I've reached out via email with details. Let me know what you think! :)

      Reply Like
    • Faness For others who may find this thread, the fix (for me) was to remove my "Bank of America (California)" connection, and replace it with just "Bank of America" . Now it connects just fine.  Not sure what broke or where, but the situation is resolved.  Thank you YBAB support for your help, y'all rock!

      Reply Like
    • Sea Green Piano Thank you for posting that here and for your kind words! If you need anything going forward, just give a shout! :)

      Reply Like
  • Having the same issue here. YNAB hasn't been able to connect to Bank of America (OK) for the past couple days. 

    Reply Like
    • Hi SLAYERinOKC !

      I refreshed the Bank of America (OK) connection and it's now saying it's successful. Can you double check things and let me know if you're still having trouble? :)

      Reply Like
    • Faness Just checked and it's connecting now! Thanks so much! :-)

      Reply Like
  • Hello - I also am getting error messages.  My account is simply Bank of America, but just keeps looping to the login when I enter my information.

    Reply Like
  • I haven't been able to connect to BOA in nYNAB for a few days. I can log in to BOA website with no problem.

    Reply Like
  • Sea Boyle Pink Mermaid (ca4c4a6a2038)

    Sorry for the trouble! We've run into a new issue with Bank of America and a number of other large financial institutions. The widespread issue is listed on our status page and has been reported to our Direct Import partner as an urgent matter. You can check in periodically there. We're hoping to see this resolved soon!

    Reply Like
      • Ivory Rain
      • Ivory_Rain.3
      • 4 mths ago
      • Reported - view

      Faness  Thanks for posting the status page...looks like i am affected by this..but the status page is great and professional. I'll wait a few days or so.  Thanks again.

      Reply Like
    • Ivory Rain We appreciate your patience! Our Direct Import partner believed they had this ironed out over the weekend, but it has proven to be a bigger change than they initially thought. They're working on this as a high priority so we're hoping for an update soon!

      Reply Like
  • I am having the same issue. I just paid for a year of YNAB but am now concerned that it won't work for me since I cant connect my main 3 accounts at BOA.  I cancelled SafePass and changed my password to try a new one and still nothing. 

    Reply Like
    • Forest Green Lobster This is a widespread issue with Bank of America, centered around a recent change in their security protocols. Our normal troubleshooting tactics aren't working here as our Direct Import partner has to rebuild part of the integration with Bank of America. This is a high priority for them so we're hoping to see an update soon!

      Reply Like
    • Faness I'm a brand new user and I can't add my BofA account.  Is there a fix for this yet??

      Reply Like
    • Hi Cadet Blue Beat !

      I'm seeing an error on your account that typically means invalid credentials have been entered. 

      Here are some things you can try that should help resolve this issue:

      — Check to make sure the URL you use to log into your online banking account matches the URL you see in YNAB.
      — Double check to make sure you're entering the correct credentials. If you’re using a password manager, try entering your login credentials in manually.
      — Log into your financial institution's online banking account, then immediately try reconnecting the account in YNAB.

      If that doesn't do the trick, please let me know!

      Reply Like
    • Faness Faness only on my initial attempt did I have a credential issue.  But after that I was definitely using the correct credentials. I successfully logged in to BofA via their website as well as on mint. I tried everything you mentioned already but nothing worked.  I started to google the issue since I was doing everything correctly. 

      Do you cache the failed attempt credentials or something?

      Reply Like
    • Cadet Blue Beat That failed attempt should bounce back to have you retry connecting. I went ahead and reported this issue to our Direct Import partner so they can take a look at what's going on. I sent you an email with a few more details and you can respond there or here if you have any questions! :)

      Reply Like
    • Faness thanks, I did the direct file import for now. Hopefully this gets solved soon!

      Reply Like 1
  • Faness Since this doesn’t seem to be getting fixed anytime soon, I would like a full refund for the year I paid for. I haven’t been able to use the system at all. Please advise on next steps. 

    Reply Like
    • Hi Forest Green Lobster !

      I took a look and your Bank of America accounts say they're currently connected successfully. However, we do have a refund guarantee. I'll reach out to you via email to confirm.

      Reply Like
  • Faness I'm having this issue: I go to login to my Bank of America account, and after giving my username and password I get the below prompt to receive an authorization code. No matter how I reply to this prompt: with my email, with the word E-mail, with the word text, it will not do anything but spit me out to a page that says "check to make sure you can sign in directly" or something like that, and I can. Please help!

    Reply Like
    • Juski21 I think I know what we can do here! I'm going to reach out from help@ynab.com so we can get this worked out. 😊

      Reply Like
  • I'm getting a similar response. I'm able to enter my username and password and then it asks "How would you like to receive the authorization code?" It shows two phone numbers which are both mine, however, after i select one it does not let me proceed to the next screen.  Any Ideas?

    Reply Like
    • Tan Saxophone (15d39084dc23) Our Direct Import partner is experiencing some issues with authenticating over the past couple of days, so this might be related.

      Keep an eye on the status page and if you can't reconnect in a day or two, please send us an email at help@ynab.com with your bank name, the URL you use to login there, and a description of the authentication issue you're seeing! We'll get this sorted :)

      Reply Like
  • Hello, I've been having issues connecting to Bank of America since July. I continue to get this error:

    Connection Tips

    For security purposes, it's expected to be frequently prompted to re-authenticate this connection, unless you choose to disable Extra Security at Sign-In or SafePass in your security settings.

     

    I can log into by BOA account from their website and I don't have extra security or safepass. Any assistance would be appreciated.

    - Emily

    Reply Like
    •  Hi Emily,

      Are you receiving a code or pin from your bank when trying to connect with YNAB? From your message, it sounds like you don't have that setting currently on your account, but I want to be sure :)

      Reply Like
    • Veronica at YNAB Hi Veronica, no I'm not being prompted to enter a PIN from my bank.

      Reply Like
    • Hi Lavender Mainframe 

      I took a look and noticed some bad connection data. We went ahead and cleared that out, so let's have you connect your accounts again. Here’s a video that will walk you through the steps below.

      --Select your budget name in the top left-hand corner and choose Manage Connections from the drop-down menu.--Then Remove the connection(s) to this financial institution, confirm removal and select Done.
      --Hover over the account that needs to be reconnected (in the left sidebar), click on the edit icon, and select ‘Link Account’.
      --Search for your financial institution and follow the prompts.

      If that doesn't do the trick, let me know and we'll go from there! :)

      Reply Like
    • Faness Hello,

      I followed the instructions and I am receiving the same error message. Shown below.

       

      Therefore I'm still unable to connect with my Bank of America accounts. Still looking for help. Thank you!

      - Emily

      Reply Like
    • Lavender Mainframe Since that didn't do the trick, I'm going to ask our Direct Import partner to investigate! I'll send you a quick email with a few more details! :)

      Reply Like
  • I am also unable to connect to my Bank of America account. I can log in directly to the bank's website. But for a month now I cannot connect via YNAB.  I've been following your status page and updates, but even though you claim that "a majority of accounts are now connected" I still cannot connect. Furthermore I am also getting a message popup when I hover over my YNAB BOA account saying, "Your authentication questions need to be answered.”, but I don’t have any authentication questions, and I don’t know what this is about. " Please help.

    Reply Like
    • Sea Green Memory I just did a bit of digging, and it looks like your BofA connection is back up and running! I am so sorry there was some miscommunication while getting to the root issue, but thanks for hanging in there with us. 😊

      Reply Like
  • I’m experiencing the exact same behavior as ‘Sea Green’ for the past week. I have verified that I’m not a robot so many time I’m beginning to feel like a robot.  Please fix this ASAP.  

    Reply Like
    • Hi Cyan Barnacle !

      I just reset your Bank of America connection. When you have a moment, can you try reconnecting? If that doesn't do the trick, just let me know and we'll take a closer look at things! :)

      Reply Like
  • I'm seeing a issue with the BoA connectivity now. I have tried all of the various tricks and nothing is working. Anyone aware of any current issues?

    Reply Like
    • Hi Sea Green Sun ! I just took a look at your connections on the backend, and it looks like BofA is back up and running! Or did you have a second set of login credentials for BofA? 

      Let me know how things are looking on your end. :) 

      Reply Like
    • Jannelle It does seem to be working now; thanks.

      Reply Like 2
  • I'm having this exact same problem with B of A. May I have some Direct Import help too?

    Reply Like
    • Hi Ashley R. !

      I took a look and I'm seeing a successful connection to Bank of America, but no linked accounts. When you have a moment, hover over the name of your Bank of America account on the left hand side of your budget and click the edit icon that appears. That will give you the option to "Link Account" - click there and then select your Bank of America connection from the list and choose your account. 

      That should get things up and running! :)

      Reply Like
      • Ashley R.
      • Project Manager that loves YNAB
      • ashley_r
      • 13 days ago
      • 1
      • Reported - view

      Faness Nice!  B of A wasn't connecting before so I couldn't link the account. Now, it is!  SWEET! Thank you. 

      Reply Like 1
  • Hi. I'm also having issues with my BofA connection. 

    Could someone advise the best course of action? 

     

    Thank you.

    Reply Like
    • Hi Lavender Ink !

      I took a look and I'm seeing an error that should clear up if you remove and then re-add that connection (don't worry, this won't affect your account history!).

      To start, you’ll remove the connection to this financial institution:

      1. Select your budget name in the top left-hand corner and choose Manage Connections from the drop-down menu.
      2. Then Remove the connection(s) to this financial institution, confirm removal and close the window.

      Then you’ll reconnect your account(s) to a fresh connection:

      3. Hover over the existing account(in the left sidebar) and click on the edit icon. 
      4. Select Link Account > Add New Connection. Search for the financial institution, and follow the prompts.

      If that doesn't do the trick, let me know and we'll go from there! :)

      Reply Like
    • Faness Perfect! Works like a charm! Thank you. 

      Reply Like 1
Like1 Follow
  • Status Answered
  • 1 Likes
  • 11 days agoLast active
  • 50Replies
  • 1665Views
  • 20 Following