USAA repeatedly breaks.

Well, the switch to Plaid was a disaster.  I finally asked to be switched over to MX as the import partner.   Everything worked great until last week.    Had to submit a ticket, and YNAB had me install some updates.  BAM, everything working great again.


Now USAA is once again broken.   What is going on?  Is this a bank issue, or a YNAB issue?  

I have no issues switching banks as USAA has been going downhill for years, but that is kind of a pain, and not sure if  YNAB has a listing of banks that work with it?   Anyone know?

12replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I have been using USAA with YNAB since they launched the online version. A few hiccups over the years but a few weeks ago (Late May 2020) Things started going weird. I unlinked accounts and later even removed and reset up the connection. Now some accounts don't even import, I get "pending" transactions a few times (that never happened before). I am going to reach out to support today.


    I did not know they had multiple import vendors and you could switch. I used to work IT at a bank and know the pain of these screen-scraping/OFX importing systems. I wish banks would do things like APIs with access keys like tech companies do.


    Your comment about USAA going downhill. I can't place my finger on it, but I can feel it too. Switching is easy but keep in mind Banks are about making profit, not serving customers. A credit union is better, but usually the technology sucks since they don't make as much profit off you. For me USAA was a good medium, but they are becoming more bank-like over the years.

  • Hey Scythe ! It looks like your USAA connection is currently successful, and transactions have recently imported. How are things looking on your end?

    To my knowledge, USAA does require regular re-authorization on all providers—but you should be able to connect and import once you do. The exact behavior can depend on the login security method you've set up, and provider.

    If you're continuing to have trouble, our importing team can help! Just reply to that last email, and we'll go from there.

    • Nicole Any word on this?

    • Matt Boomer I see you submitted the form! Thank you. These bank connections often require a closer look, and our team was able to help get that USAA connection back up & running. Let us know if you have any other questions!

  • Nicole I believe USAA just implemented required 2FA on all accounts, I have been receiving their warning emails for the last couple of weeks and thought nothing of it until YNAB started failing to import transactions. Now whenever I want USAA transactions to be imported, I need to re-authenticate to USAA which requires me to enter a 2FA code twice for some reason.

  • I'm having this problem as well. There are a couple of problems.

    1. For my login, I use an authenticator app. It seems like the YNAB/Plaid handshaking process takes longer than my 2FA code is good for. (It's a 30-second code generated by an app.) That means I can't connect my account.
    2. For my wife's login, she gets a phone call or an email. I get the requisite code, and after a while, YNAB tells me that it's connected. But a few minutes later it's all unconnected again.
    • Hi Parkaboy !

      Sorry for the trouble! If you report a Bank Importing Issue our Direct Import team can take a closer look to help you get that connection back up and running! :)

    • Parkaboy I've been having this exact same issue for the past few weeks.  As of today I can't connect at all.  It says my account isn't setup for online access.

    • Gray Transistor Thanks for submitting the form! Our importing team will check on that connection for you. 😄

    • Nicole That worked!  Thank you so much!!!

      Like 1
  • USAA has been hit or miss with staying authorized.  Seems I am a loop of reauthorize, it connects.  It doesn't import.  Then a few days later, reauthorize, it connects and yep....doesn't import.   Wash, Rinse, Repeat.


    If the problem is on YNAB's end, just say so.  IF it's a USAA problem, just say so.   The "our import partner is working the issue" is worthless at this point because it keeps happening.  It's not an issue at this point - it's a complete failure.

    Whatever the issue is, it's a continual problem with  USAA and YNAB.   YNAB should just say that USAA is problematic, and therefore not recommended to use with the import feature.

    • Hi Scythe !

      Sorry for all the trouble you've had with USAA! I see you've reached back out to support and they'll be able to provide you with a few more details of what's going on there. Usually, these issues aren't one sided - they tend to start when the financial institution makes a change on their end and our import partner has to update to accommodate that change. 

      I do see that this issue was supposed to have been resolved last week, so hopefully they're able to get that up and running for you soon! :) 

Like4 Follow
  • 1 yr agoLast active
  • 12Replies
  • 432Views
  • 6 Following