Need help with importing QFX transactions

Hi, YNAB forum. 

 

 My main bank is PNC and YNAB's importer is having issues with them -- they are working on that. My question is: I want to use QFX as the export/import format but how do I edit the QFX file so that it only imports certain dates? My PNC QFX goes back 90 days and there isn't a way to modify the date. I tried importing the QFX file but it would take me hours to clean up some 200+ transactions that don't match for whatever reason. I don't want to do that. 

 

Any suggestions?

6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • This should be trivial in YNAB: In All Accounts, sorted by date:

    1. Scroll to the first transaction with an undesired date, select/check that transaction
    2. Scroll to the last transaction with an undesired date, SHIFT-click to select that and all intervening rows
    3. Edit | Delete
    Like
  • Maybe I'm not understanding but PNC makes me take a QFX file from 90 days back, mine has 384 transactions in it. Sometimes the dates don't align etc. I would have to go through and reconcile all 384 payments and past budgets. Very annoying. Yes it would be a one-time thing but I'm trying to avoid it. 

     

    I'm wondering if there is an easy tool to edit the QFX file for say only transactions from 5>= days ago etc. 

     

    The other thing I just tried was creating a dummy account in YNAB, imported all of the 384 transactions into this, mass-deleted most of them, and then selected-all to move them into my "real" PNC account. However, it doesn't seem that YNAB did any automatic matching of transactions when using this method. :(

    Like
  • Hi Coral Colt !

    Are you seeing duplicates when you import the QFX file? If you're not able to specify a timeframe to PNC, I have a few tips! Just so you know, if you're in the same session you can undo a file import. 

    In order for a transaction imported via a file to be skipped, its direct import counterpart needs to have the exact same date and amount. The reason you're likely seeing duplicates is because the transaction dates in the file you downloaded are different than those of the directly imported transactions. 

    Try the Adjust to local time option, and you'll be able to see a preview to see if it will fix the “off-by-a-day” issue. If it works, you'll need to check that option moving forward.

    I recommend deleting the duplicate transactions and reconciling your accounts. Reconciliation will do two things for you. One, you'll know your account balance is correct, so you can trust your budget. And two, transactions dated more than 3 days prior to the last reconciled transaction aren't imported—this will at least limit (if not eliminate) duplicates moving forward.

    Like 1
    • If you need to delete the duplicates, head over to your account register (in the web app) and enter this into the search field:

      Is: Unapproved, Is: Unreconciled

      That will display any transactions in the account that have not yet been approved—and should primarily show you the duplicate imports. You can also enter a date in the search field to further narrow down the transaction list if needed. After that, you can select all the transactions you don't want to keep using the checkboxes on the left (to select all, use the top checkbox).

      Like
  • Thank you, Nicole. Big help. :)

    Like 1
    • Coral Colt Glad to hear it!

      Like
Like Follow
  • 1 mth agoLast active
  • 6Replies
  • 27Views
  • 3 Following