Scheduled transactions automatically appear as Cleared

When scheduled transactions become current they are automatically appearing as cleared. I would prefer them to remain uncleared until I clear them.  Is this possible?

10replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Did you create this account with the "Cash" type? If so, you may wish to create a checking account type and move all transactions into it.

    Like
  • Hi Chris C ! If you're unsure of the account type, we can help double check.

    Transactions entered in a cash account are automatically cleared. For other account types, the Scheduled Transactions will drop into your register uncleared—waiting for your approval.

    If you have Direct Import set up for that account, imported transactions will also be cleared automatically. 
     

    Like
  • Thanks for the replies.  I set the account up some time ago and can't remember what the account type was.  I am fairly sure that they it used to automatically clear scheduled transactions until recently, which makes me think something changed.

    It is not a direct import account.

    I can't see how to check what the account type is, so I will need help to check that.

    Like
    • Chris C A cash account is the only type that auto clears to my knowledge, and that behavior was added within the last year. I suggest you move to a new checking account. (Auto clear is not optional in the cash type.)

      Like
    • Chris C Hey, Chris! The easiest way to see if an account type is cash or checking is to enter a transaction. If it clears automatically, that's a cash account, and if not, it's checking/savings (which are exactly the same from YNAB's perspective).

      To change the account type, as dakinemaui said, you'll want to create a new account with the correct type, select all transactions in the old account and move them (Edit > Move to Account...) to the new account, and then delete the old account.

      Let me know if you run into any trouble along the way—I'm happy to help.

      Like 1
  • I think you have solved the problem. If I enter a transaction it is set to cleared.  
    i must have set up my accounts all as cash.
    One last question. Can I ‘select all’ the transactions somehow.  I have hundreds of entries going back to January 2017? I don’t want to have to select them all one by one. 

    Like
    • Chris C In a given account, click the checkbox in the header row to Select All. 

      Like
      • Chris C
      • Chris_C
      • 3 wk ago
      • 1
      • Reported - view

      dakinemaui 

      Brilliant. Thanks. I’ll let you know how I get on. 😁

      Like 1
  • Thanks to you both for the input.  Created new accounts and job done in two minutes. 🙂

    Like 2
  • There were three of you to thank - I missed out Nicole.

    It was a really irritating problem and you solved it very painlessly.

    Onward and upward......

    Like 1
Like Follow
  • 3 wk agoLast active
  • 10Replies
  • 105Views
  • 4 Following